Knowledgebase: For Administrators
Learner Receives Message “AN ERROR HAS OCCURRED WITHIN YOUR LESSON”
Posted by Heather Zauner on 02 February 2016 09:30 AM

Symptom:

User receives the following pop-up message while viewing a lesson: “AN ERROR HAS OCCURRED WITHIN YOUR LESSON. If you continue, your activity may no longer be saved.  It is recommended that you CLOSE THIS LESSON and relaunch it.”

Cause:

The Inquisiq LMS has detected a javascript error within the lesson. There is an issue with the SCORM API that impacts communication between the lesson and the LMS.

Applies To:

Inquisiq LMS versions after and including 4.15.0302.

Background:

The Inquisiq software is specifically scanning for errors within the content. When a javascript error occurs within the lesson, it breaks the connection between the lesson and the LMS and prevents the recording of the lesson data as the learner proceeds through the lesson.

This error may also occur due to an internet connection issue/timeout that occurred while the lesson was being completed.

Resolution:

Close the lesson and relaunch it.  If the issue continues, you will need to evaluate your content. To view the details of the error message...

  1. Click into the parent window.
  2. Right click the “Running Courseware” area, and select “Inspect.”

You will be given more specific details about the error within your content. You will need to consult your authoring tool vendor and/or content development team to remedy the issue.

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