Connection To SQL Failed
Posted by Brian Kleeman on 15 August 2006 02:13 PM

Symptom:

When attempting to access the LMS, you receive the following (or similar) error:

[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user 'username'. Reason: Not associated with a trusted SQL Server connection

Cause:

Your Microsoft SQL Server installation is not set for "Mixed Mode Authentication".

Background:

Microsoft SQL Server allows you to connect to it using Windows Authentication and/or SQL Server Authentication. Windows Authentication grants users that exist on the server itself access to SQL whereas SQL Server Authentication requires you to provide a login and password for an account that has been created directly in SQL Server. Mixed Mode allows both of these authentication types. By default, SQL Server installs with only Windows Authentication enabled while Inquisiq EX attempts to connect using SQL Server Authentication.

Resolution(s):

Change SQL Server over to Mixed Mode Authentication
  1. Open The SQL Server Enterprise Manager
  2. Start menu > Programs > Microsoft SQL Server > Enterprise Manager
  3. Expand the tree-control until you can your server
  4. Right click on the server name and "SQL Server Properties (Configure)" window will open
  5. Select the Security tab
  6. For "Authentication", select "SQL Server and Windows"
Set Inquisiq to use Windows Authentication
  1. Contact ICS Support for help with this resolution.


 

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