Knowledgebase: Articulate QuizMaker
TROUBLESHOOTING: Articulate Launches With Error 'Unable to Acquire LMS API'
Posted by Brian Kleeman on 09 February 2009 01:45 AM

Symptom:

When launching Articulate content, you receive a popup window with an error log containing the following errors:

Unable to acquire SCORM API

ERROR - LMS Initialize Failed

In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

Cause:

There Articulate content is not properly locating the LMS SCORM API because you have published it with an extra "launcher" window.

Applies To:

Articulate Presenter

Background:

The SCORM specification dictates where the LMS should place the SCORM API so that the Articulate code can find it and connect to it. Articulate Presenter does not adjust its search algorithm to account for the relative change in location of the LMS SCORM API when published with the launcher window.

Resolution:

Remove the launcher window from your Articulate player template and re-publish the presentation
    1. In PowerPoint, go to Articulate -> Player Template Builder -> Other -> Browser Window Settings.
    2. Uncheck the option: Launch your presentation in a new window (creates launch page)
    3. Republish your presentation using the new template.


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