Knowledgebase: System Requirements
Minimum Server Requirements for Inquisiq Installation
Posted by Joseph Carpenski on 21 June 2010 07:31 PM

Note that you may install the Inquisiq™ application and your database software on the same or different servers. If you install them on the same server, then be sure that the server meets the minimum (or recommended) requirements listed below and the minimum (or recommended) requirements of your database software as well as a reasonable buffer (i.e. running both on the same server that only meets the minimum requirements of one may not have enough resources to run both).

Applies To:

Inquisiq LMS Version 4.15.0700 and later.

Minimum Supported:

  • Dual Processor @ 2.0 GHz
  • 4 GB RAM
  • .NET Framework 3.5 Service Pack 1
  • Microsoft Windows Server 2008 R2 (Standard Edition or higher)
  • Internet Information Services (IIS) 7.x
  • Microsoft SQL Server 2008 R2 Service Pack 2 (Workgroup Edition)

 Recommended:

  • Dual Processor @ 2.0 GHz or higher
  • 8 GB RAM
  • .NET Framework 3.5 Service Pack 1
  • Microsoft Windows Server 2012 R2 (Standard Edition or higher)
  • Internet Information Services (IIS) 7.x
  • Microsoft SQL Server 2014 (Standard Edition or higher) or higher

Other Required Software and Services:

  • SMTP Service running or access to an SMTP server (for email capability)

Important Notes:

  • Inquisiq is not supported in shared server environments (such as those running Plesk, CPanel or other control panel management software).
  • Due to the "virtual site" capability of Inquisiq and its domain name based routing, it must be installed in the root folder of its own website on a dedicated IP unless otherwise recommended by technical staff.

Browser Requirements:

No more security alerts, plug-in installs or help desk calls because Inquisiq LMS has been designed with compatibility in mind. The latest browsers have converged on the XHTML standard allowing Inquisiq LMS to be universally accessible by both PC and Macintosh clients. In addition, our unique approach to the server communication issue has allowed us to avoid browser plug-ins that so often cause implementation problems in highly-secured client-server environments.

  • Google Chrome
  • FireFox
  • Microsoft Internet Explorer 10 - 11
  • Microsoft Edge
  • Safari 10 (OS X/macOS)

Important Notes:

Content that you load into the Inquisiq LMS may have additional requirements not listed here. Be sure to check the requirements of your authoring tool or with your content developer.

(1 vote(s))
Helpful
Not helpful